Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 10, 2025 - 23:00 UTC
Scheduled
We will perform scheduled maintenance on our infrastructure to improve performance. This maintenance is planned for Tuesday, June 10th, from 23:00 UTC to Wednesday, June 11th, 01:00 UTC. (7:00 PM - 9:00 PM EDT - North America).
Although the impacted customers can still access our Connect apps and REST APIs, please refrain from running business-critical write operations and data migrations (server-to-cloud migration, data residency migration) in/to the US region.
Don't hesitate to get in touch with our customer support if your organization requires assistance. We apologize for this short notice.
Posted Jun 10, 2025 - 16:04 UTC
This scheduled maintenance affected: Timesheets, Planner, Cost Tracker, JIRA, Tempo for Slack, and Tempo for Jira Cloud Help Center.