Production incident
Incident Report for Tempo
Resolved
This incident has been resolved.
Posted Jul 11, 2024 - 03:00 UTC
Investigating
Some Time Tracker users have reported the application stalling and being unresponsive. We are investigating the matter.
Posted Jul 10, 2024 - 23:33 UTC
This incident affected: Timesheets, Planner, Cost Tracker, and Tempo for Slack.