Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 17, 2025 - 19:00 UTC
Update
Due to internal circumstances, we modified the time from April 10th to 17th. The period remains unchanged: 7 PM to 9 PM UTC.
Posted Apr 04, 2025 - 20:55 UTC
Scheduled
We will perform scheduled maintenance on our infrastructure to improve performance. This maintenance is planned for Thursday, April 10th, from 7:00 PM to 9:00 PM UTC.
Although the impacted customers can still access our Connect apps and REST APIs, please refrain from running business-critical write operations and data migrations (server-to-cloud migration, data residency migration) in/to the US region.
Don't hesitate to get in touch with our customer support if your organization requires assistance. We apologize for this short notice.
Posted Apr 04, 2025 - 17:42 UTC
This scheduled maintenance affected: Timesheets, Planner, and Cost Tracker.