Missing Tempo panel on Jira issue view

Incident Report for Tempo

Update

The fix for Tempo panel is in version 1.3.21-AC of Timesheets plugin and it has currently rolled out to many of our customers. This fixes the issue with Tempo panel, and the Log time option in the Jira issue. We are currently looking into a problem with Trackers and the "w" shortcut to open the log time dialog.
Posted Jun 12, 2025 - 09:10 UTC

Update

We applied a secondary fix to the Tempo panel problem and it is currently being rolled out by Atlassian. We're continuing to monitor the situation.
Posted Jun 11, 2025 - 09:29 UTC

Identified

The issue has been identified. An update to the Tempo panel is being rolled out by Atlassian and the problem should resolve once the rollout is complete.
Posted Jun 10, 2025 - 10:44 UTC

Investigating

We have reports from customers that are missing the Tempo panel on the Jira issue view. We are investigating the issue.
Posted Jun 10, 2025 - 10:43 UTC
This incident affects: Timesheets.