Complete
end of maintenance window
In progress
Maintenance has completed andall services are confirmed to be online.
In progress
Maintenance is starting now.
Scheduled
We are planning maintenance on some critical infrastructure to improve reliability and performance. Some customers ("tenants") may experience a brief outage (several minutes) during the maintenance period.