Resolved
Monitoring
Our systems are operational again. We are monitoring.
Investigating
We're experiencing degraded performance on our US based service and are currently looking into the issue.