Service disruptions in the EU region
Resolved·Full outage

Incident has been resolved.

Fri, Nov 14, 2025, 11:16 AM
(3 days ago)
·
Affected components
Timesheets
Planner
Cost Tracker
Tempo for Slack
Updates

Resolved

Incident has been resolved.

Fri, Nov 14, 2025, 11:16 AM

Monitoring

Service disruption in EU has been fully resolved, and data sync with Jira is up to date.

Fri, Nov 14, 2025, 11:13 AM

Monitoring

We are currently experiencing slow data sync with Jira. Worklogs created on new Jira issues or newly updated Jira issues might not display correctly until after a delay.

Wed, Nov 12, 2025, 08:19 PM(1 day earlier)

Monitoring

EU production services have been restored. We will continue to monitor.

Tue, Nov 11, 2025, 10:44 PM(21 hours earlier)

Identified

A fix has been applied. We will continue to monitor the EU production environment to ensure all issues have been resolved.

Tue, Nov 11, 2025, 10:36 PM

Investigating

We are currently investigating issues reported in the Production EU region.

Tue, Nov 11, 2025, 10:34 PM
Powered by