Resolved
All the services are now stable
Monitoring
There was a potential DNS network issue from the EU cluster, and now it's recovered. We continue to monitor our infrastructure.
Investigating
In the EU region, some customers may experience outage in both public API and Connect App. We're currently troubleshooting.