Service disruptions in the EU region
Resolved·Full outage

This incident has been resolved.

Mon, Oct 13, 2025, 01:59 PM
(2 weeks ago)
·
Affected components
Timesheets
Planner
Cost Tracker
Updates

Resolved

This incident has been resolved.

Mon, Oct 13, 2025, 01:59 PM

Monitoring

We are continuing to monitor for any further issues.

Mon, Oct 13, 2025, 01:58 PM

Monitoring

EU production services have been stabilised and latency issues (slow response times) are being addressed.

Mon, Oct 13, 2025, 09:13 AM(4 hours earlier)

Monitoring

A fix has been applied. We will continue to monitor the EU production environment to ensure all issues have been resolved.

Mon, Oct 13, 2025, 08:57 AM(16 minutes earlier)

Identified

We are continuing to work on a fix for this issue.

Mon, Oct 13, 2025, 08:14 AM(42 minutes earlier)

Identified

The issue has been identified and a fix is being tested.

Mon, Oct 13, 2025, 08:09 AM

Investigating

We are currently investigating issues reported in the Production EU region.

Mon, Oct 13, 2025, 07:52 AM(16 minutes earlier)
Powered by