Partial Data Access Outage in the US region
Resolved·Degraded performance

This incident was resolved

Sat, Oct 4, 2025, 08:56 AM
(3 weeks ago)
·
Affected components
Timesheets
Planner
Cost Tracker
Updates

Resolved

This incident was resolved

Sat, Oct 4, 2025, 08:56 AM

Monitoring

Our infrastructure is now back up. We will keep monitoring the system.

Sat, Oct 4, 2025, 08:43 AM(13 minutes earlier)

Identified

We identified the issue and working on the resolution.

Sat, Oct 4, 2025, 07:56 AM(47 minutes earlier)

Investigating

We are continuing to investigate this issue.

Sat, Oct 4, 2025, 07:15 AM(41 minutes earlier)

Investigating

We are currently investigating this issue.

Sat, Oct 4, 2025, 07:02 AM(13 minutes earlier)
Powered by