Increased error rates
Incident Report for Tempo
Resolved
This incident has been resolved.
Posted May 28, 2020 - 16:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 28, 2020 - 15:17 UTC
Update
We are continuing to investigate this issue.
Posted May 28, 2020 - 14:48 UTC
Investigating
We are currently investigating this issue.
Posted May 28, 2020 - 14:25 UTC
This incident affected: Timesheets.